No Description

Jean Fromentin da3eb62b8f Base version 2 years ago
Makefile da3eb62b8f Base version 2 years ago
README.md da3eb62b8f Base version 2 years ago
monoid.cpp da3eb62b8f Base version 2 years ago
monoid.hpp da3eb62b8f Base version 2 years ago
monoid.pxd da3eb62b8f Base version 2 years ago
mred.sage da3eb62b8f Base version 2 years ago
numeric_monoid.pxd da3eb62b8f Base version 2 years ago
numeric_monoid.pyx da3eb62b8f Base version 2 years ago
setup.py da3eb62b8f Base version 2 years ago
treewalk.cpp da3eb62b8f Base version 2 years ago
treewalk.hpp da3eb62b8f Base version 2 years ago
treewalk.pxd da3eb62b8f Base version 2 years ago

README.md

NumericMonoid: Cilk++ version

This is the last and definitive version of NumericMonoid.

It requires GCC 5 and (not mandatory) Sage.

Building

If you have multiple versions of GCC installed on your system, you have to specify it to the make command:

CXX=g++-5 make MAX_GENUS=35

If you only have GCC 5 installed and wish to use the default MAX_GENUS (40), simply launch:

make